Zanurkuj w Pythonie/Instalowanie odpowiednich bibliotek

Z Wikibooks, biblioteki wolnych podręczników.
Skocz do: nawigacja, szukaj

Instalowanie odpowiednich bibliotek[edytuj]

W odróżnieniu od pozostałego kodu w tej książce, ten rozdział wymaga bibliotek, które nie są instalowane wraz z Pythonem. Zanim zanurkujemy w usługi SOAP, musisz doinstalować trzy biblioteki: PyXML, fpconst i SOAPpy.

12.2.1. Instalacja PyXML

Pierwszą biblioteką jakiej potrzebujemy jest PyXML, zbiór bibliotek do obsługi XML, które dostarczają większą funkcjonalność niż wbudowane biblioteki XML, które omawialiśmy w rozdziale 9.

Procedura 12.1.

Oto sposób instalacji PyXML:

  1. Wejdź na http://pyxml.sourceforge.net/, kliknij Downloads i pobierz ostatnią wersję dla Twojego systemu operacyjnego.
  2. Jeśli uzywasz Windowsa, to masz kilka możliwości. Upewnij się, że pobierasz wersję PyXML, która odpowiada wersji Pythona, którego używasz.
  3. Kliknij dwukrotnie na pliku instalatora. Jeśli pobrałeś PyXML 0.8.3 dla Windowsa i Pythona 2.3, to programem instalatora będzie plik PyXML-0.8.3.win32-py2.3.exe.
  4. Wykonaj wszystkie kroki instalatora.
  5. Po zakończeniu instalacji zamknij instalator. Nie będzie żadnych widocznych skutków tego, iż instalacja zakończyła się powodzeniem (żadnych programów zaistalowanych w menu Start lub nowych skrótów na pulpicie). PyXML jest po prostu zbiorem bibliotek XML używanych przez inne programy.

Aby zweryfikować czy PyXML zainstalował się poprawnie, uruchom IDE Pythona i sprawdź wersję zainstalowanych bibliotek XML, tak jak w tym przykładzie.

Przykład 12.3. Weryfikacja instalacji PyXML

>>> import xml
>>> xml.__version__
'0.8.3'

Ta wersja powinna odpowiadać numerowi wersji instalatora PyXML, który pobrałeś i uruchomiłeś.

12.2.2. Instalacja fpconst

Drugą biblioteką jaką potrzebujemy jest fpconst, zbiór stałych i funkcji do obsługi wartości zmienno-przecinkowych IEEE754. Dostarcza ona wartości specjalne To-Nie-Liczba (ang. Not-a-Number) (NaN), Dodatnia Nieskończoność (ang. Positive Infinity) (Inf) i Ujemna Nieskończonosć (ang. Negative Infinity) (-Inf), które są częścią specyfikacji typów danych SOAP.

Procedura 12.2.

A oto procedura instalacji fpconst:

  1. Pobierz ostatnią wersję fpconst z http://www.analytics.washington.edu/statcomp/projects/rzope/fpconst/ lub http://www.python.org/pypi/fpconst/.
  2. Są tam dwa pliki do pobrania, jeden w formacie .tar.gz, a drugi w formacie .zip. Jeśli używasz Windowsa, pobierz ten w formacie .zip; w przeciwnym razie ten w formacie .tar.gz.
  3. Rozpakuj pobrany plik. W Windows XP możesz kliknąć prawym przyciskiem na pliku i wybrać pozycję Extract All; na wcześniejszych wersjach Windowsa będzie potrzebny dodatkowy program, np. WinZip. Na Mac OS X możesz kliknąć dwukrotnie na spakowanym pliku, aby go rozpakować przy pomocy Stuffit Expander.
  4. Otwórz okno linii poleceń i przejdź do katalogu, w którym rozpakowałeś pliki fpconst.
  5. Wpisz python setup.py install, aby uruchomić program instalujący.

Aby zweryfikować, czy fpconst zainstalował się prawidłowo, uruchom IDE Pythona i sprawdź numer wersji.

Przykład 12.4. Weryfikacja instalacji fpconst

>>> import fpconst
>>> fpconst.__version__
'0.6.0'

Ten numer wersji powinien odpowiadać wersji archiwum fpconst, które pobrałeś i zainstalowałeś.

12.2.3. Instalacja SOAPpy

Trzecim i ostatnim wymogiem jest sama biblioteka: SOAPpy.

Procedura 12.3.

A oto procedura instalacji SOAPpy:

  1. Wejdź na http://pywebsvcs.sourceforge.net/ i wybierz Ostatnie Oficjalne Wydanie (ang. Latest Official Release) w sekcji SOAPpy.
  2. Są tam dwa pliki do wyboru. Jeśli używasz Windowsa, pobierz plik .zip; w przeciwnym wypadku pobierz plik .tar.gz.
  3. Rozpakuj pobrany plik, tak jak to zrobiłeś z fpconst.
  4. Otwórz okno linii poleceń i przejdź do katalogu, w którym rozpakowałeś pliki SOAPpy.
  5. Wpisz python setup.py install, aby uruchomić program instalujący.

Aby zweryfikować, czy SOAPpy zostało zainstalowane poprawnie, uruchom IDE Pythona i sprawdź numer wersji.

Przykład 12.5. Weryfikacja instalacji SOAPpy

>>> import SOAPpy
>>> SOAPpy.__version__
'0.11.4'

Ten numer wersji powinien odpowiadać wersji archiwum SOAPpy, które pobrałeś i zainstalowałeś.