QCad CE - podręcznik użytkownika/Menu "Edycja"

Z Wikibooks, biblioteki wolnych podręczników.
Przejdź do nawigacji Przejdź do wyszukiwania

Dzięki menu Edycja możemy modyfikować istniejące na rysunku obiekty bazowe. Menu otwieramy klikając na ikonce Qcad edit icon.png na głównym pasku narzędzi rysowniczych lub wybierając menu Modify na pasku głównym:

Qcad modification toolbar.png

Przesuń (kopiuj)[edytuj]

Menu: Modify>Przesuń/kopiuj

Dzięki poleceniu można przesunąć lub skopiować obiekty bazowe, można też stworzyć wielokrotne kopie. Procedura:

  1. Kiedy wybierzesz opcję Przesuń pokaże się pasek narzędzi Zaznacz - wybierz obiekty, które chcesz przesunąć/skopiować.
  2. Kliknij dolną strzałkę w prawo na pasku narzędzi Zaznacz.
  3. Wstaw punkt odniesienia, klikając w wybranym miejscu rysunku lub wpisując współrzędne kartezjańskie w wierszu poleceń.
  4. Wstaw punkt docelowy przy pomocy myszy lub wpisując współrzędne kartezjańskie bezwzględne lub względne (używając @).
  5. Wyświetli się okienko dialogowe:
    • Usuń oryginał spowoduje przeniesienie obiektu do wskazanego punktu
    • Zachowaj oryginał spowoduje skopiowanie obiektu do wskazanego miejsca
    • Kopie wielokrotne rysunek zostanie skopiowany n ilość razy, we wskazanym kierunku
    • Użyj bieżących atrybutów skopiowany rysunek będzie miał bieżące, aktywne atrybuty, inne niż rysunek źródłowy
    • Użyj bieżącej warstwy skopiowany rysunek zostanie przeniesiony na aktywną warstwę

Obracaj[edytuj]

Menu: Modify>Obracaj

Polecenie pozwala obrócić wybrane obiekty bazowe o dany kąt. Procedura:

  1. Kiedy wybierzesz opcję Obracaj pokaże się pasek narzędzi Zaznacz - wybierz obiekty, które chcesz obrócić.
  2. Kliknij dolną strzałkę w prawo na pasku narzędzi Zaznacz.
  3. Wstaw punkt obrotu, klikając w wybranym miejscu rysunku lub wpisując współrzędne kartezjańskie w wierszu poleceń.
  4. Wyświetli się okienko dialogowe:
    • Usuń oryginał spowoduje przeniesienie obiektu
    • Zachowaj oryginał spowoduje skopiowanie obiektu
    • Kopie wielokrotne rysunek zostanie skopiowany n ilość razy, pod wskazanym kątem
    • Użyj bieżących atrybutów obrócony rysunek będzie miał bieżące, aktywne atrybuty, inne niż rysunek źródłowy
    • Użyj bieżącej warstwy obrócony rysunek zostanie przeniesiony na aktywną warstwę

Skaluj[edytuj]

Menu: Modify>Skaluj

Dzięki poleceniu można przeskalować obiekty bazowe. Procedura:

  1. Kiedy wybierzesz opcję Skaluj pokaże się pasek narzędzi Zaznacz - wybierz obiekty, które chcesz przeskalować.
  2. Kliknij dolną strzałkę w prawo na pasku narzędzi Zaznacz.
  3. Wstaw punkt odniesienia, klikając w wybranym miejscu rysunku lub wpisując współrzędne kartezjańskie w wierszu poleceń.
  4. Wyświetli się okienko dialogowe, gdzie podajemy wartość, o jaką obiekt ma zostać przeskalowany względem punktu odniesienia:
    • Usuń oryginał spowoduje przeniesienie przeskalowanego obiektu do wskazanego punktu
    • Zachowaj oryginał spowoduje skopiowanie przeskalowanego obiektu do wskazanego miejsca
    • Kopie wielokrotne rysunek zostanie przeskalowany n ilość razy, względem punktu odniesienia
    • Użyj bieżących atrybutów skalowany rysunek będzie miał bieżące, aktywne atrybuty, inne niż rysunek źródłowy
    • Użyj bieżącej warstwy skalowany rysunek zostanie przeniesiony na aktywną warstwę

Odbij[edytuj]

Menu: Modify>Odbijaj

Dzięki poleceniu można odbić obiekty bazowe, względem wskazanej prostej. Procedura:

  1. Kiedy wybierzesz opcję Odbij pokaże się pasek narzędzi Zaznacz - wybierz obiekty, które chcesz odbić.
  2. Kliknij dolną strzałkę w prawo na pasku narzędzi Zaznacz.
  3. Wstaw pierwszy punkt odniesienia, klikając w wybranym miejscu rysunku lub wpisując współrzędne kartezjańskie w wierszu poleceń.
  4. Wstaw drugi punkt odniesienia, tworząc prostą przy pomocy myszy lub wpisując współrzędne kartezjańskie bezwzględne lub względne (używając @).
  5. Wyświetli się okienko dialogowe:
    • Usuń oryginał spowoduje przeniesienie obiektu do wskazanego punktu
    • Zachowaj oryginał spowoduje skopiowanie obiektu do wskazanego miejsca
    • Użyj bieżących atrybutów odbity rysunek będzie miał bieżące, aktywne atrybuty, inne niż rysunek źródłowy
    • Użyj bieżącej warstwy odbity rysunek zostanie przeniesiony na aktywną warstwę

Przesuń i obróć[edytuj]

Menu: Modify>Przesuń i obróć

Dzięki poleceniu można jednocześnie przesunąć lub skopiować obiekty bazowe i je obrócić, można też stworzyć wielokrotne kopie. Procedura:

  1. Kiedy wybierzesz opcję Przesuń i obróć pokaże się pasek narzędzi Zaznacz - wybierz obiekty, które chcesz przesunąć i obrócić.
  2. Kliknij dolną strzałkę w prawo na pasku narzędzi Zaznacz.
  3. Wstaw punkt odniesienia, klikając w wybranym miejscu rysunku lub wpisując współrzędne kartezjańskie w wierszu poleceń.
  4. Wstaw punkt docelowy przy pomocy myszy lub wpisując współrzędne kartezjańskie bezwzględne lub względne (używając @).
  5. Wyświetli się okienko dialogowe, gdzie wpisuje się kąt, o jaki obiekt ma zostać obrócony:
    • Usuń oryginał spowoduje przeniesienie i obrócenie obiektu do wskazanego punktu
    • Zachowaj oryginał spowoduje skopiowanie i obrócenie obiektu do wskazanego miejsca
    • Kopie wielokrotne rysunek zostanie skopiowany i obrócony n ilość razy, we wskazanym kierunku
    • Użyj bieżących atrybutów skopiowany rysunek będzie miał bieżące, aktywne atrybuty, inne niż rysunek źródłowy
    • Użyj bieżącej warstwy skopiowany rysunek zostanie przeniesiony na aktywną warstwę

Obracaj dookoła dwóch środków[edytuj]

Menu: Modify>Obracaj (to niższe)

Dzięki poleceniu można obrócić obiekty bazowe wokół dwóch środków, można też stworzyć wielokrotne kopie. Procedura:

  1. Kiedy wybierzesz opcję Obracaj pokaże się pasek narzędzi Zaznacz - wybierz obiekty, które chcesz obrócić.
  2. Kliknij dolną strzałkę w prawo na pasku narzędzi Zaznacz.
  3. Wstaw bezwzględny punkt obrotu, klikając w wybranym miejscu rysunku lub wpisując współrzędne kartezjańskie w wierszu poleceń.
  4. Wstaw względny punkt obrotu przy pomocy myszy lub wpisując współrzędne kartezjańskie bezwzględne.
  5. Wyświetli się okienko dialogowe, gdzie wpisuje się wartość kąta obrotu a i b:
    • Usuń oryginał spowoduje przeniesienie obiektu do wskazanego punktu
    • Zachowaj oryginał spowoduje skopiowanie obiektu do wskazanego miejsca
    • Kopie wielokrotne rysunek zostanie skopiowany n ilość razy, we wskazanym kierunku
    • Użyj bieżących atrybutów skopiowany rysunek będzie miał bieżące, aktywne atrybuty, inne niż rysunek źródłowy
    • Użyj bieżącej warstwy skopiowany rysunek zostanie przeniesiony na aktywną warstwę

Przytnij/przedłuż[edytuj]

Menu: Modify>Przytnij

Polecenie pozwala wydłużyć lub obciąć obiekt bazowy (linię lub łuk) względem innego ograniczającego obiektu bazowego. Procedura:

  1. Kliknij na obiekcie ograniczającym.
  2. Kliknij obiekt do wydłużenia/przycięcia. Klikasz zawsze tę część obiektu, która ma pozostać na rysunku.
  3. Kliknij dwukrotnie prawym przyciskiem myszy lub wciśnij escape aby wyłączyć narzędzie.

Przytnij/przedłuż dwa[edytuj]

Menu: Modify>Przytnij dwa

Można przeciąć lub wydłużyć dwa przecinające się obiekty bazowe (linie i/lub łuki). Procedura:

  1. Kliknij na pierwszym obiekcie ograniczającym.
  2. Kliknij na drugim obiekcie ograniczającym.
  3. Kliknij dwukrotnie prawym przyciskiem myszy lub wciśnij escape aby wyłączyć narzędzie.

Przytnij o wartość[edytuj]

Menu: Modify>Przedłuż

Linie lub łuki można wydłużyć lub przyciąć o dowolną wartość. Procedura:

  1. Wybranie opcji Przytnij o wartość spowoduje wyświetlenie pola tekstowego na pasku opcji. W polu wpisujemy wartość wydłużenia obiektu - ujemne wartości skróca obiekt.
  2. Kliknij na obiekcie bazowym, bliżej końca, który chcesz wydłużyć lub skrócić.
  3. Kliknij dwukrotnie prawym przyciskiem myszy lub wciśnij escape aby wyłączyć narzędzie.

Zetnij[edytuj]

Menu: Modify>Zetnij

Opcja pozwala ściąć róg dowolnego konturu. Procedura:

  1. Wybranie opcji Zetnij spowoduje wyświetlenie pola tekstowego na pasku opcji. W polu wpisujemy wartość x i y obciętego rogu (odległości od odcinanego rogu). Możemy też zdecydować, czy róg ma zostać odcięty, czy pozostać.
  2. Kliknij pierwszą linię lub łuk.
  3. Kliknij drugą linię lub łuk.

Zaokrąglaj[edytuj]

Menu: Modify>Zaokrąglaj

Opcja pozwala zaokrąglić róg dowolnego konturu. Procedura:

  1. Wybranie opcji Zaokrąglaj spowoduje wyświetlenie pola tekstowego na pasku opcji. W polu wpisujemy wartość kąta zaokrąglonego rogu. Możemy też zdecydować, czy róg ma zostać odcięty, czy pozostać.
  2. Kliknij pierwszą linię lub łuk.
  3. Kliknij drugą linię lub łuk.

Podzielona[edytuj]

Menu: Modify>Divide

Dzielenie obiektu bazowego na dwa obiekty. Polecenie wykonuje się klikając obiekt do podziału i następnie wybierając punkt podziału.

Rozciągaj[edytuj]

Menu: Modify>Rozciągaj

Polecenia pozwala rozciągnąć kontury obiektów. Procedura:

  1. Wybierz przy pomocy myszki okno, w którym znajdują się obiekty do rozciągnięcia.
  2. Wskaż punkt odniesienia, klikając lewym przyciskiem myszy lub wpisując współrzędne punktu w wierszu poleceń.
  3. Określ punkt końcowy.

Edytuj geometrię obiektu[edytuj]

Menu: Modify>Właściwości

Pozwala na edycję właściwości i geometrii obiektów bazowych, wyświetlając okienko dialogowe Właściwości.

Edytuj atrybuty obiektu[edytuj]

Menu: Modify>Atrybuty

Pozwala zmienić atrybuty gruby obiektów bazowych.

Usuń[edytuj]

Menu: Modify>Usuń, Modify>Usuń zaznaczone Klawisz skrótu: delete

Pozwala usunąć z rysunku obiekty bazowe. Należy zaznaczyć obiekty do usunięcia i kliknąć dolną, prawą strzałkę - zaznaczone obiekty zostaną usunięte.

Wybuch[edytuj]

Menu: Modify>Rozbij

Pozwala zamienić obiekty takie jak bloki, tekst, spline, kreskowanie i wymiary na obiekty bazowe. Użycie dwukrotne pozwala rozbić na najbardziej podstawowe obiekty. Tekst zostanie rozbity na linie i łuki.

Podziel tekst na litery[edytuj]

Menu: Modify>Rozbij tekst na litery

Używając opcji Rozbij tekst na litery, można rozbić napisy na pojedyncze litery.

Edytuj tekst[edytuj]

Funkcja działa tak samo jak Właściwości, z tą różnicą, że dla tekstu.