C Sharp/Potrzebne narzędzia

Z Wikibooks, biblioteki wolnych podręczników.
Przejdź do nawigacji Przejdź do wyszukiwania

Potrzebne narzędzia[edytuj]

Potrzebne narzędzia[edytuj]

Do programowania w języku C# wymagane są biblioteki. Są one dostępne w paczkach, które nazywa sie frameworkami. Są trzy najpopularniejsze frameworki:

  • .NET Framework - stworzone przez Microsoft, najszybciej aktualizowane. Aktualna wersja: 4.5.2
  • Mono - open-sourcowy framework wspomagany przez koncern Novell, który pozwala odpalić nasze aplikacje w Linuxie bądź MacOSie. Niestety rozwój tego frameworka jest znacznie wolniejszy, niż rozwój oryginalnego rozwiązania MS.
  • DotGNU - projekt, który ma na celu uruchomienie programu na niemal każdej platformie, chociażby na XBoxie 360 bądź Playstation3.

Po ściągnięciu pakietu framework potrzebujemy albo edytora tekstu i dodatkowego kompilatora, albo IDE - zintegrowanego środowiska programistycznego. Ściągając IDE automatycznie ściągamy także kompilator, nie musimy martwić się o dodatkowe szukanie. Każdy z tych frameworków posiada własne profilowane środowisko. Dla MS .NET Framework

  • Visual Studio 2013
  • Visual Studio 2015
  • Visual Studio Community
  • Visual Studio Code
  • SharpDevelop
  • MonoDevelop
  • Xamarin Studio

Dla Mono

  • MonoDevelop (działa również na .NET Framework 3.5, jednak trzeba doinstalować bibliotekę Gtk#)

Dla DotGNU takowe środowisko nie istnieje, lecz jest udostępniony kompilator na oficialnej stronie tego projektu.

Często dla lepszego zrozumienia kodu będziemy pisać w Notatniku lub Notepad++. Pozwoli to nauczyć się podstawowych technik programistycznych bez pomocy IDE.

Poprzedni rozdział: O podręczniku
Spis treści
Następny rozdział: Używanie kompilatora