OpenOffice.org/Calc/Funkcje/Funkcja JEŻELI

Z Wikibooks, biblioteki wolnych podręczników.
Przejdź do nawigacji Przejdź do wyszukiwania

Funkcja JEŻELI – funkcja wbudowana w arkusz kalkulacyjny OpenOffice Calc (kategoria logiczne). Przedstawia jedną wartość, jeśli warunek zawarty w funkcji jest spełniony (PRAWDA), lub wartość drugą, jeśli warunek nie jest spełniony (FAŁSZ).

Składnia funkcji
JEŻELI(warunek;wartość_jeśli_PRAWDA;Wartość_jeśli_FAŁSZ)
  A B C D
1 -2 =JEŻELI(A1>0;"PEŁNA";"PUSTA") PUSTA
2 2 "=JEŻELI(A1>0;"Większa niż zero";JEŻELI(A1<0;"Mniejsza od zera";"Równa zero")) "Mniejsza od zera"
3 3 =JEŻELI(I(A2<=3,1;A3<150);"jeden";"niejeden")&JEŻELI(I(A2>3,1;A2<=3,4;A3<150);"dwa";"niedwa") jedenniedwa
4 =JEŻELI(I(A2<=3,1;A3<150);150;50)/JEŻELI(I(A2>3,1;A2<=3,4;A3<150);2;3) 50
5
6
7
Przykład 1
Jeżeli w komórce A1 jest liczba ujemna, zero lub komórka jest pusta, to w komórce, gdzie jest wpisana formuła (np. B1), zostanie wpisany tekst "PUSTA". Jeżeli ten warunek nie jest spełniony (A1 zawiera liczbę większą od zera albo tekst), to zostanie wpisany tekst "PEŁNA".

=JEŻELI(A1>0;"PEŁNA";"PUSTA")

Przykład 2
Funkcję JEŻELI można zagnieżdżać, uzyskując możliwość spełnienia więcej niż jednego warunku.

=JEŻELI(A1>0;"Większa niż zero";JEŻELI(A1<0;"Mniejsza od zera";"Równa zero"))

Przykład 3
Jeśli zamierzasz użyć w jednej formule wiele razy osobnej funkcji JEŻELI, należy po każdej z nich wpisać znak wynikający z typu tworzonej formuły obliczeniowej. Dla formuły tekstowej będzie to znak &, dla formuły arytmetycznej może to być dowolny z operatorów.
a.[edytuj]

=JEŻELI(I(A2<=3,1;A3<150);"jeden";"niejeden")&JEŻELI(I(A2>3,1;A2<=3,4;A3<150);"dwa";"niedwa")

b.[edytuj]

=JEŻELI(I(A2<=3,1;A3<150);150;50)/JEŻELI(I(A2>3,1;A2<=3,4;A3<150);2;3)