Przejdź do zawartości

OpenOffice.org/Instalacja słowników

Z Wikibooks, biblioteki wolnych podręczników.

OpenOffice.org umożliwia korzystanie z bezpłatnych narzędzi do korekty pisowni w wielu językach oraz odpowiednich zasad przenoszenia wyrazów. Dla wielu języków dostępne są też bezpłatne słowniki synonimów. W każdej wersji językowej pakietu można zainstalować wiele różnych słowników.

Oprócz opisanych niżej metod instalacji użytkownicy Linuksa mogą skorzystać po prostu z pakietów przygotowanych przez dystrybutorów. Najczęściej w wypadku instalacji OpenOffice.org w polskiej wersji systemu słowniki są instalowane automatycznie. Twórcy dystrybucji takich jak Fedora czy Ubuntu nie umożliwiają automatycznej aktualizacji słowników za pomocą opisanej niżej metody; należy korzystać z wewnętrznych narzędzi dystrybucji. Jeśli to także niemożliwe, pozostaje tylko instalacja ręczna.

Do korekty gramatycznej nie służą słowniki, lecz oddzielne rozszerzenia. Takim rozszerzeniem jest LanguageTool, zapewniający korektę stylistyczną, rozbudowane testy poprawności ortograficznej i stylistycznej dla angielszczyzny, niemczyzny, polszczyzny i holenderskiego. Proste reguły istnieją już też dla innych języków.

Instalacja automatyczna z Internetu[edytuj]

Krok 1 – uruchomienie kreatora

Aby zainstalować słowniki, w programie OpenOffice.org wybierz polecenie Plik → Kreatory → Zainstaluj nowe słowniki. Otworzy się nowe okno, gdzie należy kliknąć link Polski (w OpenOffice.org 2.3 należy jednocześnie nacisnąć klawisz Ctrl i kliknąć link). To nie jest na razie wybór słowników, ale wybór polskiej wersji kreatora. Kliknij przycisk Uruchom DicOOo. Następnie kliknij przycisk Dalej.

Krok 2 – wybieranie pakietów do zainstalowania

Po prawej stronie okienka znajduje się napis Słowniki sprawdzania pisowni. Kliknij przycisk Pobierz listę.

Uwaga: może pojawić się okno informujące o nowej wersji kreatora DicOOo. Na razie nie należy uaktualniać kreatora. (Informacje o aktualizacji DicOOo znajdują się niżej).

Zaznacz języki do zainstalowania. Można wybrać kilka (np. słownik angielski, niemiecki, polski), klikając z naciśniętym przyciskiem Ctrl.

Krok 3 – wybieranie słowników do instalacji

Po wybraniu kliknij przycisk Dalej. Teraz po prawej stronie pojawi się napis Słownik podziału wyrazów. Ten słownik służy do poprawnego podziału przenoszonych do kolejnego wiersza wyrazów. Kliknij przycisk Pobierz listę. Wybierz języki do zainstalowania w tej grupie. Kliknij przycisk Dalej.

Teraz po prawej stronie widać napis Tezaurusy. Tezaurusy są to słowniki wyrazów bliskoznacznych. Kliknij przycisk Pobierz listę. Wybierz języki do zainstalowania w tej grupie. Kliknij przycisk Dalej.

Krok 4 – instalacja wybranych słowników

Za chwilę rozpocznie się pobieranie wybranych słowników. Jeśli słowniki są aktualizowane, warto usunąć zaznaczenie pola Nie pobieraj słowników.... Kliknij przycisk Dalej. Następnie rozpocznie się pobieranie i instalacja. Kliknij przycisk Zakończ. Ponownie uruchom OpenOffice.org (w wypadku korzystania z szybkiego uruchamiania, należy zakończyć go, klikając go prawym przyciskiem myszy w pasku zadań ikonę OpenOffice.org i wybierając polecenie Zakończ).

Krok 5 – sprawdzenie ustawień

Na koniec sprawdź, czy polski słownik jest ustawiony jako domyślny. W OpenOffice.org kliknij kolejno Narzędzia → Opcje → Ustawienia językowe → Pisownia. Kliknij przycisk Edytuj. Z listy rozwijanej można wybrać domyślny język.

Instalacja półautomatyczna bez Internetu[edytuj]

Jeśli nie mamy aktualnie połączenia z Internetem lub po prostu posiadamy już pakiet słowników, to możemy go wskazać kreatorowi (w drugim kroku). Pakiet powinien być wcześniej pobrany na dysk, nie należy go rozpakowywać - wystarczy wskazać kreatorowi ściągnięty plik ZIP.

Aktualny polski pakiet językowy można ściągnąć ze strony pl.openoffice.org.

Inne języki stąd. Oddzielnie słownik wyrazów, podziału i tezaurus można pobrać stąd.

Słownik można także zainstalować jako rozszerzenie aplikacji. Słowniki można pobrać z stąd. Następnie otwieramy plik, po akceptacji i restarcie aplikacji mamy dostępny zainstalowany słownik.

Instalacja ręczna[edytuj]

Wprowadzenie[edytuj]

W aktualnych wersjach OpenOffice.org słowniki znajdują się w katalogu: /katalog_instalacji/share/dict/ooo (w systemie Windows - \katalog_instalacji\share\dict\ooo), przy czym w instalacji wielostanowiskowej można również zainstalować słowniki tylko dla poszczególnych użytkowników, w ich katalogach OpenOffice.org.

Po standardowej instalacji w wyżej wymienionym katalogu znajduje się plik dictionary.lst, oraz pliki z rozszerzeniami .aff, .dic, .dat oraz .idx. Nazwy plików zwykłych słowników składają się z symbolu języka wraz z jego odmianą (dialektem), np. de_DE, de_AT, czy de_CH (np. pl_PL.dic). Skrót hyph_ przed określeniem języka oznacza, że to plik słownika automatycznego dzielenia wyrazów, np. hyph_pl_PL.dic; nazwy plików tezaurusa, czyli słownika synonimów, zaczynają się od znaków th_, np. th_en_US.dat lub th_en_US.idx.

Należy sprawdzić, czy w katalogu słowników znajdują się potrzebne pliki. W razie potrzeby można pobrać je z oficjalnej strony OpenOffice.org:

  1. http://pl.openoffice.org/addons.index.html#slowniki
  2. http://lingucomponent.openoffice.org/download_dictionary.html (wszystkie języki).

Słowniki dostępne są także bezpośrednio na stronach ich twórców:

  1. http://www.kurnik.org/dictionary/alt-myspell-pl.zip
  2. http://synonimy.sourceforge.net.

Edycja pliku dictionary.lst[edytuj]

Plik ten jest po prostu listą słowników używanych przez program. Trzeba wpisać słowniki używanych języków oraz podać (bez rozszerzenia!) nazwy plików, np.:

DICT pl PL pl_PL
HYPH pl PL hyph_pl_PL
THES pl PL th_pl_PL_v2
DICT de DE de_DE
DICT de AT de_AT
HYPH de DE hyph_de
DICT en US en_US
HYPH en US hyph_en_US
THES en US th_en_US_v2

Uwaga. Od wersji 2.0 programu OpenOffice.org stosowany jest nowy format słownika synonimów. Aby zaznaczyć, że plik jest w nowym formacie, twórcy słowników stosują przyrostek _v2 po nazwie pliku (np. th_pl_PL_v2).

Włączenie słowników[edytuj]

W menu NarzędziaOpcjeUstawienia językowePisownia, w okienku Dostępne moduły języków zaznaczamy poszczególne opcje sprawdzania pisowni, od góry: sprawdzanie pisowni jako takiej, następnie automatyczne dzielenie wyrazów (uwaga: jest to tylko włączenie słownika, a nie procesu dzielenia wyrazów!) oraz słownik synonimów. Jest to ustawienie ogólne; włączenie (lub wyłączenie) poszczególnych słowników dla wybranych języków wykonujemy po naciśnięciu przycisku Edytuj, kolejno dla języków na liście rozwijanej. Brak znacznika wyboru przy danym języku oznacza nieprawidłową instalację słownika. W okienku Opcje wybieramy np. sprawdzanie we wszystkich językach lub inne ustawienia, np. sposoby dzielenia wyrazów.

Aktualizacja kreatora DicOOo[edytuj]

Z adresu http://ftp.services.openoffice.org/pub/OpenOffice.org/contrib/dictionaries/dicooo/DicOOo.sxw należy pobrać nowy plik i zastąpić już istniejący plik o tej samej nazwie w katalogu ze słownikami, czyli:

/katalog_instalacji/share/dict/ooo (w systemie Windows - \katalog_instalacji\share\dict\ooo)

Uwagi[edytuj]

  • Żeby prawidłowo działała funkcja podpowiedzi dla źle napisanych słów, trzeba zadbać o poprawne określenie języka tekstu. W tym celu zaznaczamy cały tekst lub fragment (w wypadku tekstów wielojęzycznych) i z menu kontekstowego albo menu Format wybieramy polecenie Znak, a następnie na karcie Czcionka z listy rozwijanej wybieramy odpowiedni język. Wygodnym rozwiązaniem jest zarejestrowanie makr do określania języka, wtedy wystarczy zaznaczyć interesujący fragment i nacisnąć odpowiedni przycisk lub skrót.
  • Włączanie słowników dla wielu języków i jednoczesne ustawienie opcji Sprawdź we wszystkich językach może spowolnić pracę programu.
  • Ręczne dzielenie wyrazów uzyskujemy (Ctrl+-), spróbuj tez automatycznego dzielenia: Akapit->Przepływ tekstu -> Dzielenie wyrazów -> Automatycznie.