QCad CE - podręcznik użytkownika/Praca z plikami

Z Wikibooks, biblioteki wolnych podręczników.
Przejdź do nawigacji Przejdź do wyszukiwania

QCad Community Edition 2 obsługuje pliki w formacie drawing exchange format z rozszerzeniem dxf, kompatybilne z plikami tworzonymi w programie AutoCAD w wersjach starszych niż ACAD 2000 włącznie. Kompatybilność nie jest idealna, ale w wielu przypadkach akceptowalna.

Główny pasek narzędzi do obsługi plików wygląda jak na poniższym screenie, gdzie po kolei ikony odpowiadają za funkcje: Nowy rysunek, Otwórz rysunek, Zapisz rysunek

Qcad toolbar1.png
Tworzenie nowego rysunku[edytuj]

Menu: File>Nowy
Skrót: Ctrl+N

Tworzy nowy, pusty rysunek. Możesz utworzyć szablon zawierający np. obramowanie i inne, często używane elementy. Możesz też skorzystać z gotowych szablonów w Partlibrary, dostępnych w menu View>Views>Library browser w folderze templates.

Otwieranie zapisanego rysunku[edytuj]

Menu: File>Otwórz...
Skrót: Ctrl+O

Polecenie otwiera okienko dialogowe wyboru zapisanego pliku. QCad otwiera pliki w formacie DXF i ładuje jako aktywne okno. Można otworzyć wiele rysunków i przełączać się między nimi, korzystając z menu Window. Warto zwrócić uwagę na fakt, że niektóre obiekty bazowe, zwłaszcza te bardziej skomplikowane jak czcionki i wymiarowanie, mogą być ignorowane przez program, jeżeli stworzyliśmy przy użyciu innej aplikacji. Importując więc plik utworzony innym programem, warto zapisać go pod inną nazwą, aby przypadkowo nie usunąć z niego jakiś informacji.

Zapisywanie rysunku[edytuj]

Menu: File>Zapisz i File>Zapisz jako...
Skrót: Ctrl+S

Polecenie to zapisuje bieżący rysunek na dysk. Jeżeli chcemy zapisać rysunek pod inną nazwą, wybieramy opcję Zapisz jako..., wyświetli się okienko dialogowe z wyborem nazwy pliku, rodzaju oraz miejsca zapisania.

Eksportowanie rysunku do formatu rastrowego[edytuj]

Menu: File>Eksportuj...

Możemy wyeksportować bieżący rysunek do pliku obrazu rastrowego, mającego inne właściwości niż plik wektorowy DXF. Mamy możliwość wyboru kilku popularnych formatów: bmp, jpg, pbm, pgn, pmg (domyślny), ppm, xbm, xpm. Podczas eksportu program pyta jeszcze o rozdzielczość końcowego rysunku rastrowego.

Zamykanie rysunku[edytuj]

Menu: File>Zamknij
Skrót: Ctrl+W

Polecenie zamyka bieżący rysunek i w przypadku istniejących niezapisanych zmian, wyświetla okno dialogowe z pytanie, czy zapisać zmiany na dysk.

Podstawowa edycja plików[edytuj]

Qcad toolbar edition.png

Cofnij[edytuj]

Menu: Edit>Cofnij
Skrót: Ctrl+Z
Polecenie: undo, u lub cofnij, c

Polecenie odwołuje ostatnią wprowadzoną zmianę. Można cofnąć wiele zmian, ponawiając polecenie. Niektórych operacji nie można cofnąć,

Ponów[edytuj]

Menu: Edit>Ponów
Skrót: Ctrl+Shift+Z
Polecenie: redo, r lub przywroc, pr

Przywraca ostatnio cofniętą zmianę.

Wytnij[edytuj]

Menu: Edit>Wytnij
Skrót: Ctrl+X

Wywołanie komendy uruchomi pasek z narzędziami zaznaczania. Po zaznaczeniu wybranych elementów i kliknięciu ikonki strzałki elementy zostaną usunięte z bieżącego rysunku i zapisane do pamięci podręcznej. Można je potem przywrócić w dowolnym miejscu rysunku poleceniem Wklej.

Kopiuj[edytuj]

Menu: Edit>Kopiuj
Skrót: Ctrl+C

Polecenie działa adekwatnie jak polecenie Wytnij z tą różnicą, że obiekty nie są usuwane z bieżącego rysunku.

Wklej[edytuj]

Menu: Edit>Wklej
Skrót: Ctrl+V

Poleceniem można wstawić do rysunku obiekt aktualnie znajdujący się w pamięci podręcznej schowka. Komenda jest użyteczna przy przenoszeniu obiektów pomiędzy różnymi rysunkami - kopiowane są wtedy także warstwy i dodawane do listy warstw. Należy uważać przy kopiowaniu bloków - różne bloki powinny mieć różne nazwy, jeżeli używamy opcji, przenosząc je lub kopiując między rysunkami.